No announcement yet.

Live USB doesn't find any drives to install to

  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Live USB doesn't find any drives to install to

    I borked my kubuntu (and windows) installs by doing a stupid win11 update, no idea what happened.

    The kubuntu drive won't boot, says can't find partitions or something - might have to dig into that later. I used a new kubuntu 22.04.2 live usb to boot, and it did, but the kubuntu environment does not show any attached drives, even though there is an nvm and ssd attached to the sata port.

    gparted doesn't show anything other than the usb drive, and dolphin doesn't either.

    secure boot is off - because the usb won't boot with secure boot on, and the windows nvm drive boots from both enabled and disabled secure boot.

    I just want to see if my drive is totally corrupted now, or if the data is recoverable, but the drives don't show up at all.

    Is there a special bios setting that is needed to get the usb live kubuntu to recognize drives? I have never had this happen before, and i know the windows computers are getting more and more locked out from allowing linux.

    Last edited by suplero; Mar 10, 2023, 06:02 AM.

    Simple fix - after doing some digging.

    The key is the achi setting - apparently in the windows update, the bios got changed back to the intel setting that wasn't achi, and all the drives were achi setup.

    When the drives tried to boot afterwards they failed.

    Booting into the kubuntu live usb session after setting the bios mode to achi worked, as did just rebooting directly to the actual drives.


      Just to put things right in case someone else with a similar problem is looking for a solution:

      This UEFI/BIOS setting for Serial ATA (SATA) controllers is called AHCI (not "achi") = "Advanced Host Controller Interface".
      Desktop: Debian 11 KDE & LXQt • Kubuntu 22.04 & 20.04 • openSUSE KDE • Windows 10 • Lenovo ThinkCentre M710s
      Nvidia GT 1030 • Intel i5-7600 • 16 GB RAM • 256 GB Toshiba XG4 M.2 SSD • 1 TB Crucial MX500 SSD • 512 GB Kingston KC600 SSD
      Laptop: Kubuntu 22.04 • macOS X 15 • Apple MacBook Pro (13-inch, Mid 2012)
      Intel HD 4000 • Intel i7-3520M • 16 GB RAM • 1024 GB Kingston KC600 SSD


        And to add to the above, some laptops and PCs default to using Intel's RST (a RAID thingy) here, which does not support Linux at all, and thus installers are unable to see the drives that are set to use it.
        If the drive has Windows already installed using this, one may need to do some extra steps to switch Windows from using the RST drivers as well, before you proceed.
        1. Boot into Windows
        2. Open a shell as administrator
        3. Run bcdedit /set safeboot minimal
        4. Reboot, enter BIOS and switch to AHCI
        5. Reboot into Windows again (you will be in safe mode, which will cause the OS to detect the switch to AHCI, and remove the RST drivers safely and automatically)
        6. Open another shell as administrator
        7. Run bcdedit /deletevalue safeboot
        8. Reboot