Announcement

Collapse
No announcement yet.

How to prevent "edge snap" from snapping to inside border

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to prevent "edge snap" from snapping to inside border

    Snap to Edge snaps to the inside of the window border on some applications. I dislike this. I want the entire window border visible on all edges. I find no Setting tht seems relevant. But there is likely a way to prevent this behavior in a kde/kubuntu configuration file. Anyone know how?

    Regards.

    22.04 LTS fully up-to-date

    #2
    hello, and welcome!

    I am not sure what you mean exactly by "inside of the window border" , but that is probably just me being dense
    However, as this is only happening on *some* applications, I am guessing that these likely are ones that simply don't/won't follow the rules, so to speak.
    Can you list some of the offending ones?

    I'd ask for screenshots but you won't be able to post those until you have hit 3 posts, nor urls for the same iirc.
    I'll ask Jeeves

    Comment


      #3
      claydoh - thanks for your reply.

      Let's see if I can explain this. I'm using Oxygen for my windows decorations. It draws window titlebars, and about a 5-pixel border around the left, bottom, and right edges of all windows. Thus there is an inside edge to the window border ("inside border) and an "outside border" for each window.

      With snap-to-edge enabled, when either left, bottom, or right windows snap to a screen edge the border disappears, because the "feature" snaps to the "inside border" and not the "outside border". I very much dislike this behavior. I have a 24" HD monitor. I have a lot of screen real estate and I don't care about saving 5 pixels on a window border. Thing is other compositing "features" mean that the window edge has shadow, etc. that obscure that edge of the window that had snapped-to-edge.

      I see options in the Preferences for setting the width of region in which snap-to-edge is triggered, but I see nothing that affects which parts of the window get covered up when snap engages.

      I'm hoping there is some configuration magic someone may know of to prevent this behavior. I'm having no luck with Google.

      Thanks.

      Comment


        #4
        I don't see any config options that would do this, even arcane manual options in ~/config/kwinrc or similar areas.
        This might be worth filing a bug/wishlist on bugs.kde.org against kwin (I think)
        I am not sure of this is something built in to the themes themselves, or into the window manager. Kvantum or other engines might have useful configurations for this sort of thing, but might not have the desired window decoration.
        I'll ask Jeeves

        Comment


          #5
          Originally posted by gstalnaker View Post
          Snap to Edge snaps to the inside of the window border on some applications. I dislike this.
          I like it (I begrudge every pixel, across two monitors and the laptop screen), but some time in the past it stopped. In investigating your issue, I mucked around trying the settings button on various "window decorations", and changing the window border size, and the snap to the inside of the window border has come back! I'm sorry, I can't say what affected it.
          Regards, John Little

          Comment

          Working...
          X