Announcement

Collapse
No announcement yet.

Kubuntu 20.04 on older laptop extremely slow boot - snap problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Kubuntu 20.04 on older laptop extremely slow boot - snap problem?

    Hello,
    I just installed Kubuntu 20.04 on an older Dell Inspiron 1545, replacing a long-outdated Mint 17.3 KDE installation.

    The problem is that the machine takes extremely long to boot -- it takes well over 2 minutes from power-up to the login prompt, and another 35 seconds to get a usable desktop. For comparison, I reinstalled the old Mint 17.3 KDE, and that fully booted in just 1:20, so half the time.

    A new install of Kubuntu once again booted slow. Some searching suggests that snap may be related to this problem, and this is what I see with df -h:
    Code:
    [FONT=monospace][COLOR=#000000]df -h [/COLOR]
    File System        Size     Used Avail Use% Mounted on
    udev               1,4G        0  1,4G   0% /dev
    tmpfs              295M     1,5M  293M   1% /run
    /dev/sda1           19G      14G  3,8G  79% /
    tmpfs              1,5G        0  1,5G   0% /dev/shm
    tmpfs              5,0M     4,0K  5,0M   1% /run/lock
    tmpfs              1,5G        0  1,5G   0% /sys/fs/cgroup
    /dev/loop0         128K     128K     0 100% /snap/bare/5
    /dev/loop1         132M     132M     0 100% /snap/chromium/2011
    /dev/loop2         134M     134M     0 100% /snap/chromium/2020
    /dev/loop4          56M      56M     0 100% /snap/core18/2344
    /dev/loop3          56M      56M     0 100% /snap/core18/2409
    /dev/loop6          62M      62M     0 100% /snap/core20/1494
    /dev/loop5          62M      62M     0 100% /snap/core20/1518
    /dev/loop7         165M     165M     0 100% /snap/gnome-3-28-1804/161
    /dev/loop9         401M     401M     0 100% /snap/gnome-3-38-2004/112
    /dev/loop8         255M     255M     0 100% /snap/gnome-3-38-2004/106
    /dev/loop10         82M      82M     0 100% /snap/gtk-common-themes/1534
    /dev/loop12         47M      47M     0 100% /snap/snapd/16010
    /dev/loop13         47M      47M     0 100% /snap/snapd/16292
    /dev/loop11         92M      92M     0 100% /snap/gtk-common-themes/1535
    /dev/sda7           48G      24K   45G   1% /home2
    /dev/sda5          156G      39G  117G  26% /home
    tmpfs              295M      12K  295M   1% /run/user/1000[/FONT]
    It would seem that well over 1.5GB of loop devices is mounted, which would explain the slow boot upon startup. (And yes, losetup -a shows them all mounted.)

    Now I wanted to see if removing the Chromium browser would make a noticeable difference, so I uninstalled all installed Chromium packages using the Muon package manager.

    However, and to my surprise, Chromium is still installed and active, both in this list of snaps as well as in the KDE menu. Yet it does no longer show up as installed in the package manager.
    Now I have some questions:
    • How do I completely uninstall Chromium?
    • Could snap be linked with the slow boot problem?
    • If so, how can I get rid of snap?
    • If this is not possible, how can I reduce the number of active snap loop devices?
    Frankly, I am not impressed with Kubuntu. I thought it was the best replacement for the aforementioned Mint 17.3 KDE install, but after installing it on 4 different machines, I find that I am annoyed by several issues, including this slow start problem (which in fact happens on another machine as well) and the same screen flickering issue mentioned here: https://www.kubuntuforums.net/forum/...g-new-programs.

    I hope that in particular this slow boot can be fixed, otherwise I think I'll try another distro altogether.

    Thanks in advance,

    #2
    Muon does not manage Snaps in any way at all.
    Snaps can be uninstalled from within Discover, but for more control, you can use the command line.
    .

    snap list
    snap remove
    something
    All those loops are items that need to be mounted, and of course will slow boot times.

    You can uninstall all your snaps, and then snapd altogether (using apt), or try removing all those extra snaps you have. You don't need all of them, I am sure. if you had the ~2 or 3 snaps normally used for chromium it probably would not be so slow at all.
    I am not sure if there is a built in way to clean out unused or unneeded snaps, similar to running apt autoremove for native packages.

    Originally posted by RichardR View Post
    A new install of Kubuntu once again booted slow.
    A new install of 20.04 would not have any snaps installed whatsoever. If it is slow *before* you have installed a bunch of things, then snaps are not really the whole problem.

    Originally posted by RichardR View Post
    Mint 17.3 KDE install,
    This would actually be Kubuntu 14.04

    Maybe some hardware specs might help, as that is an 8 year old core OS and KDE (KDE 4)
    I'll ask Jeeves

    Comment


      #3
      Thank you for your quick reply, and confirming that those snaps may well be the cause of the slow boot.

      I checked some of the other three recent Kubuntu installations, and indeed two of them have no snap applications installed at all, so I'm a bit puzzled where those snaps came from on that ancient laptop (hardware: dual Pentium 2.4GHz, 4 GB RAM and an older 5400 RPM SATA HD). I certainly did not install it explicitly, but maybe I unthinkingly said 'yes' when asked if it snap should be installed, e.g. when installing or updating things from the CLI.

      A fourth machine was recently upgraded to Kubuntu 22.04, and during that upgrade, a message said that Firefox would henceforth only be available as snap. So correct me if I'm wrong, but it seems that the newest Kubuntu version does force the use of snap, if only for Firefox right now.
      I'm not sure if this is a good development - power users with a lot of heavy applications may eventually end up with many GB's of loop devices that will negatively impact system performance, especially at boot time. This may be less of a problem with ultra-fast modern SSD-HD's, but old-style HD's are absolutely affected.

      So based on this and my experiences, I think that Kubuntu is no longer a good choice, at least for older hardware - I think I'll give MX Linux KDE a try this weekend, and see how that works out ...

      Thanks again, regards,

      ADDENDUM: it seems that the suspicions about snap applications causing noticeable performance issues are indeed justified: https://www.omgubuntu.co.uk/2022/05/...nap-app-faster
      Last edited by RichardR; Jul 14, 2022, 04:00 AM.

      Comment


        #4
        I have a similar machine (Celeron processors) and a boot time of 1:30 is typical. Fastest booting distros were Solus and Manjaro but they are both rolling and newer software is often more demanding. So, you trade that little advantage at boot with slower performance eventually. I got the best all around result with Lubuntu 20.04 on that machine; reasonable boot time and a responsive desktop.

        Comment

        Working...
        X