Announcement

Collapse
No announcement yet.

More samba problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    More samba problems

    Well, I am back again with more samba problems. I finally had it with my upstairs PC given me the "runs" and wiped and installed kubuntu 20.04 (from a corrupted version of 18.04) Still can't get Samba to work correctly. If I navigate to Network -> SMB -> ThisHostName -> I can see and get all the shares, BUT, it's listed as "smb://hostname.local/share" If I navigate to Network -> NETWORK -> ThisHostName -> I can see a two listings for ThisHostName. One is from an unknown source. The second is a picture of a folder with a global (globe) on it. It shows that it redirects to "smb://ThisHostName.local:445/" Networked Computer Whichever way I go, I now have a new login box, which goes no further. See Attachment
    Attached Files

    #2
    Samba

    Is there a more professional Samba support forum ? Is there a more modern guide. (sick to death of guides from the 1940's...) Sorry 2011 Besides the two Kubunto 20.04 talking to each other, I also need the following .Remote desktop. My knees are really starting to hurt .access to the shares from a windowsXP machine to index stored files on the drives. The Upstairs PC is mostly used as file storage and media playback for the kids. And I don't give a **** about security, so the picture shows my workgroup and hostname. Don't frigging care. If I don't get anywhere with this, I'm going back to 18.04. At least samba/remote desktop f***ing worked there without any problems. Nor do I care about edicate in this group. I've had enough of Samba not working since 20.04 upgrade

    Comment


      #3
      I'm sorry you're having such problems, @CharlieDaves. Getting Samba working can be a bit of a pain.

      Have you tried using gAdmin-Samba? If it's not installed, look for gadmin-samba using your favorite package manager (I use Synaptic) and install it, then fire it up. Most of its pages/entries won't need to be fiddled with, but looking at them can reveal, and allow you to fix, the source of the problem.

      FWIW, Samba works fine for me on 20.04; I have nothing but Kubuntu and Android devices in my house.
      Xenix/UNIX user since 1985 | Linux user since 1991 | Was registered Linux user #163544

      Comment


        #4
        Originally posted by DoYouKubuntu View Post
        I'm sorry you're having such problems, @CharlieDaves. Getting Samba working can be a bit of a pain. Have you tried using gAdmin-Samba? .
        Yes thanks. I've used that on one then both pcs, but besides 'root' being the only user on some shares, it doesn't help with what is going WRONG. I've managed to get the kubuntu shares to work, BUT with
        Code:
        smb://mohad-badeel[b].local[/b]/share
        WindowsXP now sees the workgroup, and the kubuntu PCs, but will NOT log in to them. I am slowly making my way through the smb.conf switches, but it is difficult What is it with the .local bit on the hostname. I cannot find any information out about it. This is even across the network. Is this some update with samba?

        Thanks Apologies for the language earlier. I was very frustrated. (And I had to ICE my knee last night)
        Attached Files

        Comment


          #5
          Can anyone explain the difference between client and server in reference to client min/max protocol & server min/max protocol Since I have set my PC to be a standalone server? If I set client max protocol = smb2_02 the winxp pc wont even access the workgroup. If I set client max protocol = NT1 then it can access the workgroup, see the linux pcs. but I get prompted for username & password (which is rejected) Out of frustrutation I mashed in F*** and other obsenties, and low and behold I gain access onto the linux pc and cane see (but not accesss) the shares. Seriously WTF is going on? Have I locked it down too much?

          Comment


            #6
            FIXED. Finally

            So. After weeks of change this, change that, restarts. figured it out.
            Added the following to SMB [Global]
            NTML = yes
            min protocol = NT1
            max protocol = SMB2_02

            As for Server and Client min-max protocol, I still don't have a flipping clue

            Comment


              #7
              Now I have a new problem
              any file or folder copied or moved is default permission as 'ROOT'
              Seriously WTF is going on ??
              Please. Anyone. Help

              SEE ALSO https://www.kubuntuforums.net/showth...900#post445900
              Last edited by CharlieDaves; Apr 20, 2021, 10:23 PM.

              Comment


                #8
                I remember, but too tired ATM to remember, but there was another way to network share besides Samba... I think you had to setup a server, or have one PC acting as a server. I have 2 computers, both now running 20.04, one with virtualbox, and other useful things installed. The other with 'other useful' things removed (basically everything but firefox & VLC media player), KDE connect for my tablet. VM of Winxp only for cataloguing software that for the life of me I cannot get a newer version or even a Linux version https://visual-cd.en.softonic.com/
                Why is it so complicated to "share" files and folders?
                Why is it, most of my copied files and folders default to ROOT ?
                Is it normal for the network shares to suddenly have <hostname>.LOCAL as the share name, with lastest version of Samba and/or Kubuntu 20.04 ?

                Anyone? Please?

                Comment


                  #9
                  Yes, they appeared with .local at first, but I changed the server and client minimum protocol to samba 1.0. I also did some other changes, here is my smb.conf changes for 20.04 that works well with Dolphin and computers running sundry Linux distros, and also with Windows:

                  [global]

                  ## Browsing/Identification ###

                  # Change this to the workgroup/NT-domain name your Samba server will part of
                  workgroup = MYGROUP
                  netbios name = MYCOMPUTER
                  # lanman auth = no
                  ntlm auth = yes
                  # client lanman auth = no
                  wins support = yes
                  local master = yes
                  preferred master = yes

                  # server string is the equivalent of the NT Description field
                  server string = %h server (Samba, Ubuntu)



                  #### Networking ####

                  # The specific set of interfaces / networks to bind to
                  # This can be either the interface name or an IP address/netmask;
                  # interface names are normally preferred
                  ; interfaces = 127.0.0.0/8 eth0

                  # Only bind to the named interfaces and/or networks; you must use the
                  # 'interfaces' option above to use this.
                  # It is recommended that you enable this feature if your Samba machine is
                  # not protected by a firewall or is a firewall itself. However, this
                  # option cannot handle dynamic or non-broadcast interfaces correctly.
                  ; bind interfaces only = yes

                  # Dolphin can only use old version:
                  client min protocol = NT1
                  server min protocol = NT1

                  #### Debugging/Accounting ####

                  # This tells Samba to use a separate log file for each machine
                  # that connects
                  log file = /var/log/samba/log.%m

                  ...the rest the same.

                  You need a workgroup for things to work nicely with samba 1.0.

                  The only problem is the directories you share won't be writable (you can do everything else) but their subdirectories will.

                  Example of the shares added at the end (the Windows 11 partition is mounted after decripting, since it comes BitLocked):

                  [WINDOWS11]
                  path = /media/bitlockermount
                  writeable = yes
                  browseable = yes
                  guest ok = yes

                  [Downloads]
                  ; comment = Downloads
                  path = /home/myusername/Downloads
                  ; valid users = @everybody
                  ; force group = +everybody
                  writeable = yes
                  browseable = yes
                  guest ok = yes


                  The Downloads directory, for example, I cannot write anything to it. So you can mkdir a subdirectory there to have ready to put files in it. It's weird, but that works.

                  Some people solved that problem by renaming the share from [Downloads] to something different, but it didn't work for me.




                  PS: Of course if you have Windows machines you need to enable the Samba 1.0 protocol in them. Google for it. It's NOT recommended to use it unless your network is very safe, behind a proper firewall and a router with all the protections. Even so, older NAS still running Samba 1.0 are very vulnerable to attack, so I'd recommend to never make their controls accessible from outside the network. If you need to remote into your network regularly, get a newer router or use some old computer as a router.

                  Comment

                  Working...
                  X